Solaris needs _XPG4_2 for ancilliary data (fixes: #3040)