Qt4.3 compatibility.