The current libvlc-control ABI is not compatible with the 0.8.6 one. Change SONAME.