We want to check QT4 version at runtime rather than buildtime
authorRafaël Carré <funman@videolan.org>
Sat, 8 Mar 2008 12:53:08 +0000 (13:53 +0100)
committerRafaël Carré <funman@videolan.org>
Sat, 8 Mar 2008 12:53:08 +0000 (13:53 +0100)
Revert "thanks for Trolltech fixing their mess, after a bug request that using valgrind caused the same kind of problem."

This reverts commit d8fc5a1ddb75eb9d53fc090ad1e5e8bfe2522bb0.

modules/gui/qt4/qt4.cpp

index 26e1e04..fa2b279 100644 (file)
@@ -287,8 +287,8 @@ static void Init( intf_thread_t *p_intf )
 
     Q_INIT_RESOURCE( vlc );
 
-#if !defined(WIN32) && !defined(__APPLE__) && QT_VERSION < 0x040400
-    /* KLUDGE for QT4 < 4.4.0 (which use libgconf to avoid that)
+#if !defined(WIN32) && !defined(__APPLE__)
+    /* KLUDGE:
      * disables icon theme use because that makes Cleanlooks style bug
      * because it asks gconf for some settings that timeout because of threads
      * see commits 21610 21622 21654 for reference */