Lets assume glibc 2.8 will work properly when it's out (though I doubt it)
authorRémi Denis-Courmont <rem@videolan.org>
Wed, 28 Nov 2007 17:23:39 +0000 (17:23 +0000)
committerRémi Denis-Courmont <rem@videolan.org>
Wed, 28 Nov 2007 17:23:39 +0000 (17:23 +0000)
NEWS
src/vlc.c

diff --git a/NEWS b/NEWS
index 3df8dc1..0509d07 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,8 @@ Changes between 0.8.6 and 0.9.0-svn (not released yet):
 
 Important notes:
 ----------------
+ * On Linux, localization will be disabled if you have glibc 2.6 or 2.7 due
+   to a major bug in libintl with these glibc versions.
  * The HTTP interface is now only available on the local machine by default.
    If you want to make it available from other machines, you will have to
    edit the ".hosts" file.
index 828ea26..e9190c8 100644 (file)
--- a/src/vlc.c
+++ b/src/vlc.c
@@ -67,7 +67,7 @@ int main( int i_argc, const char *ppsz_argv[] )
     int i_ret;
 
 #   ifdef __GLIBC__
-    if (dlsym (RTLD_NEXT, "sync_file_range"))
+    if (dlsym (RTLD_NEXT, "sync_file_range") && !dlsym (RTLD_NEXT, "qsort_r"))
     {
         /* Way too many Linux users have glibc 2.6 that keeps crashing
          * inside its non-thread-safe dcgettext(). */