Be more restrictiv wrt wx version.
authorChristophe Mutricy <xtophe@videolan.org>
Wed, 27 Sep 2006 15:28:32 +0000 (15:28 +0000)
committerChristophe Mutricy <xtophe@videolan.org>
Wed, 27 Sep 2006 15:28:32 +0000 (15:28 +0000)
configure.ac

index 20d2c76..3b0e59b 100644 (file)
@@ -4703,9 +4703,9 @@ then
   AC_PATH_PROG(WX_CONFIG, ${WXWIDGETS_NAME}, no, ${WXWIDGETS_PATH})
   if test "${WX_CONFIG}" != "no" -a "${CXX}" != ""
   then
-    if expr 2.3.0 \> `${WX_CONFIG} --version` >/dev/null
+    if expr 2.6.0 \> `${WX_CONFIG} --version` >/dev/null ||  expr 2.7.0 \<= `${WX_CONFIG} --version` >/dev/null
     then
-      AC_MSG_ERROR([Your development package for wxWidgets is too old, you need at least version 2.3.0. Please upgrade and try again. Alternatively you can also configure with --disable-wxwidgets.])
+      AC_MSG_ERROR([You need wxWidgets of the 2.6 branch. Please upgrade and try again. Alternatively you can also configure with --disable-wxwidgets.])
     fi
     AC_LANG_PUSH(C++)
     # Turn this error: