Disable update checking per default, re-enable with --enable-update-check
authorRafaël Carré <funman@videolan.org>
Fri, 14 Dec 2007 17:53:27 +0000 (17:53 +0000)
committerRafaël Carré <funman@videolan.org>
Fri, 14 Dec 2007 17:53:27 +0000 (17:53 +0000)
commit48c2ac8c879a83c4f8737b978ca9c3232bb2e70d
tree96fc54b6b655909e6c2de5745bf7083e987b1682
parent2f06355e0303965a82189b1d9b0aedc4ef9aa9fc
Disable update checking per default, re-enable with --enable-update-check
Add OpenPGP code, still unused as there is no download of binaries at the moment

We will need to define (and write) the files (and their location) we will use in the update system:

    * We will use a file per arch, which will be signed
    * ALL VideoLAN gpg public keys will be stored on http://download.videolan.org/pub/keys/XXXXXXXXXXXXXXXX.asc where XXXXXXXXXXXXXXXX is the long id of the key
    * Every downloadable file will be signed with gpg --sign --detach --armor
18 files changed:
configure.ac
doc/release-howto.txt
include/vlc_update.h
modules/control/rc.c
modules/gui/macosx/intf.h
modules/gui/macosx/intf.m
modules/gui/macosx/update.h
modules/gui/macosx/update.m
modules/gui/qt4/dialogs/help.cpp
modules/gui/qt4/dialogs/help.hpp
modules/gui/qt4/dialogs_provider.cpp
modules/gui/qt4/dialogs_provider.hpp
modules/gui/qt4/menus.cpp
modules/gui/wxwidgets/dialogs.cpp
modules/gui/wxwidgets/dialogs/updatevlc.cpp
modules/gui/wxwidgets/dialogs/updatevlc.hpp
modules/gui/wxwidgets/interface.cpp
src/misc/update.c