Contrib: Patches updates for Win32 compile of FFmpeg and libass.
[vlc.git] / extras / contrib / src / Patches / ffmpeg-svn-win32.patch
index bd715fc..d06af7a 100644 (file)
@@ -1,24 +1,11 @@
-Index: configure
-===================================================================
---- configure  (rĂ©vision 17381)
-+++ configure  (copie de travail)
-@@ -1359,7 +1359,7 @@
-     die "C compiler test failed."
+--- configure.orig     2009-07-26 00:06:36.000000000 +0200
++++ configure  2009-07-26 00:08:21.000000000 +0200
+@@ -1674,7 +1674,7 @@
  fi
  
+ add_cppflags -D_ISOC99_SOURCE -D_POSIX_C_SOURCE=200112
 -check_cflags -std=c99
 +#check_cflags -std=c99
- case "$arch" in
-     i386|i486|i586|i686|i86pc|BePC)
-@@ -1531,8 +1531,8 @@
-         objformat="win32"
-         enable dos_paths
-         if ! enabled x86_64; then
--            check_cpp_condition _mingw.h "(__MINGW32_MAJOR_VERSION > 3) || (__MINGW32_MAJOR_VERSION == 3 && __MINGW32_MINOR_VERSION >= 15)" ||
--                die "ERROR: MinGW runtime version must be >= 3.15."
-+            check_cpp_condition _mingw.h "(__MINGW32_MAJOR_VERSION > 3) || (__MINGW32_MAJOR_VERSION == 3 && __MINGW32_MINOR_VERSION >= 13)" ||
-+                die "ERROR: MinGW runtime version must be >= 3.13."
-             enabled_any avisynth vfwcap_demuxer &&
-                 { check_cpp_condition w32api.h "(__W32API_MAJOR_VERSION > 3) || (__W32API_MAJOR_VERSION == 3 && __W32API_MINOR_VERSION >= 13)" ||
-                   die "ERROR: avisynth and vfwcap_demuxer require w32api version 3.13 or later."; }
+ check_cc -D_FILE_OFFSET_BITS=64 <<EOF && add_cppflags -D_FILE_OFFSET_BITS=64
+ #include <stdlib.h>
+ EOF