* debian/rules:
[vlc.git] / debian / control
1 Source: vlc
2 Section: graphics
3 Priority: optional
4 Maintainer: Sam Hocevar (Debian packages) <sam+deb@zoy.org>
5 Build-Depends: debhelper (>=3.4.4), gettext, fortune-mod, xlibs-dev, xlibs-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libsdl1.2-dev (>=1.2.2-3.1), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>=0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi2-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, dvb-dev, libdv2-dev, libxosd-dev, svgalibg1-dev (>=1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev, libdvdplay0-dev (>=1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>=1.1.0), libimlib2-dev, libmatroska-dev, libfreetype6-dev
6 Build-Conflicts: libmpeg2-dev, libmpeg2-0-dev, libmpeg2-1-dev, libmpeg2-2-dev, libmpeg2-3-dev
7 Standards-Version: 3.6.0
8
9 Package: vlc
10 Section: graphics
11 Architecture: any
12 Depends: ${shlibs:Depends}, ${misc:Depends}
13 Recommends: gnome-vlc | wxvlc, ttf-freefont | ttf-thryomanes
14 Suggests: fortune-mod
15 Replaces: vlc-plugin-dvb (<< 0.5.2-2), vlc-plugin-xosd (<< 0.5.2-2), vlc-plugin-dv (<< 0.5.2-2), vlc-plugin-mad (<< 0.5.2-2), vlc-mad (<< 0.5.0), vlc-plugin-a52 (<< 0.5.2-2), vlc-plugin-ogg (<< 0.5.2-2), vlc-plugin-lirc (<< 0.5.2-2), vlc-lirc (<< 0.5.0), vlc-plugin-aa (<< 0.5.2-2), vlc-aa (<< 0.5.0)
16 Conflicts: vlc-plugin-dvb (<< 0.5.2-2), vlc-plugin-xosd (<< 0.5.2-2), vlc-plugin-dv (<< 0.5.2-2), vlc-plugin-mad (<< 0.5.2-2), vlc-mad (<< 0.5.0), vlc-plugin-a52 (<< 0.5.2-2), vlc-plugin-ogg (<< 0.5.2-2), vlc-plugin-lirc (<< 0.5.2-2), vlc-lirc (<< 0.5.0), vlc-plugin-aa (<< 0.5.2-2), vlc-aa (<< 0.5.0)
17 Provides: mp3-decoder
18 Description: multimedia player for all audio and video formats
19  This is the VideoLAN project's VLC media player. It plays MPEG, MPEG2,
20  MPEG4, DivX, MOV, WMV, QuickTime, mp3, Ogg/Vorbis files, DVDs, VCDs, and
21  multimedia streams from various network sources.
22  .
23  VLC can also be used as a streaming server that duplicates the stream it
24  reads and multicasts them through the network to other clients, or serves
25  them through HTTP.
26  .
27  VLC has support for on-the-fly transcoding of audio and video formats,
28  either for broadcasting purposes or for movie format transformations.
29
30 Package: libvlc0-dev
31 Section: libdevel
32 Architecture: any
33 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
34 Description: development files for VLC
35  This package contains headers and a static library required to build plugins
36  for VLC, or standalone applications that use VLC features.
37
38 Package: gnome-vlc
39 Section: gnome
40 Architecture: any
41 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
42 Recommends: vlc-plugin-esd
43 Conflicts: vlc-gnome (<< 0.5.0)
44 Replaces: vlc-gnome (<< 0.5.0)
45 Provides: vlc-gui
46 Description: GNOME frontend for VLC
47  This plugin adds a GNOME interface to the VLC media player. To activate
48  it, use the `--intf gnome' flag or run the `gnome-vlc' program.
49
50 Package: gvlc
51 Architecture: any
52 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
53 Conflicts: vlc-gnome (<= 0.2.63-2), vlc-gtk (<< 0.5.0)
54 Replaces: vlc-gnome (<= 0.2.63-2), vlc-gtk (<< 0.5.0)
55 Provides: vlc-gui
56 Description: GTK+ frontend for VLC
57  This plugin adds a GTK+ interface to the VLC media player. To activate
58  it, use the `--intf gtk' flag or run the `gvlc' program.
59
60 Package: vlc-plugin-esd
61 Architecture: any
62 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
63 Conflicts: vlc-esd (<< 0.5.0)
64 Replaces: vlc-esd (<< 0.5.0)
65 Description: Esound audio output plugin for VLC
66  This plugin adds support for the Enlightened Sound Daemon to the VLC
67  media player. To activate it, use the `--aout esd' flag or select the
68  `esd' audio output plugin from the preferences menu.
69
70 Package: vlc-plugin-alsa
71 Architecture: any
72 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
73 Conflicts: vlc-alsa (<< 0.5.0)
74 Replaces: vlc-alsa (<< 0.5.0)
75 Description: ALSA audio output plugin for VLC
76  This plugin adds support for the Advanced Linux Sound Architecture to
77  the VLC media player. To activate it, use the `--aout alsa' flag or
78  select the `alsa' audio output plugin from the preferences menu.
79
80 Package: vlc-plugin-sdl
81 Architecture: any
82 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
83 Conflicts: vlc-sdl (<< 0.5.0)
84 Replaces: vlc-sdl (<< 0.5.0)
85 Description: SDL video and audio output plugin for VLC
86  This plugin adds support for the Simple DirectMedia Layer library to
87  the VLC media player. To activate it, use the `--vout sdl' or
88  `--aout sdl' flags or select the `sdl' video or audio output plugin
89  from the preferences menu.
90
91 Package: vlc-plugin-ggi
92 Architecture: any
93 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
94 Conflicts: vlc-ggi (<< 0.5.0)
95 Replaces: vlc-ggi (<< 0.5.0)
96 Description: GGI video output plugin for VLC
97  This is a GGI plugin for the VLC media player.  To activate it, use
98  the `--vout ggi' flag or select the `ggi' video output plugin from the
99  preferences menu.
100
101 Package: vlc-plugin-glide
102 Architecture: i386
103 Depends: vlc (= ${Source-Version}), libglide2
104 Conflicts: vlc-glide (<< 0.5.0)
105 Replaces: vlc-glide (<< 0.5.0)
106 Description: Glide video output plugin for VLC
107  This is a Glide (3dfx) plugin for the VLC media player. To activate
108  it, use the `--vout glide' flag or select the `glide' video output
109  plugin from the preferences menu.
110
111 Package: qvlc
112 Architecture: any
113 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
114 Conflicts: vlc-qt (<< 0.5.0)
115 Replaces: vlc-qt (<< 0.5.0)
116 Provides: vlc-gui
117 Description: Qt frontend for VLC
118  This plugin adds a Qt interface to the VLC media player. To activate it,
119  use the `--intf qt' flag or run the `qvlc' program.
120
121 Package: vlc-plugin-arts
122 Architecture: any
123 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
124 Conflicts: vlc-arts (<< 0.5.0)
125 Replaces: vlc-arts (<< 0.5.0)
126 Description: aRts audio output plugin for VLC
127  This plugin adds support for the aRts Sound System to the VLC media
128  player. To activate it, use the `--aout arts' flag or select the `arts'
129  audio output plugin from the preferences menu.
130
131 Package: mozilla-plugin-vlc
132 Architecture: any
133 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
134 Recommends: mozilla-browser
135 Description: multimedia plugin for Mozilla based on VLC
136  This plugin adds support for MPEG, MPEG2, DVD, DivX, Ogg/Vorbis and many
137  more formats to your Mozilla browser. The decoding process is done by VLC
138  and the output window is embedded in a webpage or directly in the browser
139  window. There is also support for fullscreen display and javascript control.
140
141 Package: kvlc
142 Section: kde
143 Architecture: any
144 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
145 Recommends: vlc-plugin-arts
146 Conflicts: vlc-kde (<< 0.5.0)
147 Replaces: vlc-kde (<< 0.5.0)
148 Provides: vlc-gui
149 Description: KDE frontend for VLC
150  This plugin adds a KDE interface to the VLC media player. To activate it,
151  use the `--intf kde' flag or run the `kvlc' program.
152
153 Package: vlc-plugin-svgalib
154 Architecture: i386
155 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
156 Description: SVGAlib video output plugin for VLC
157  This plugin adds support for SVGAlib to the VLC media player. To
158  activate it, use the `--vout svgalib' flag or select the `svgalib' video
159  output plugin from the preferences menu. Note that you will need root
160  permissions to use SVGAlib.
161
162 Package: wxvlc
163 Architecture: any
164 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}, ${misc:Depends}
165 Provides: vlc-gui
166 Description: wxWindows and skins frontends for VLC
167  This plugin adds a wxWindow interface and a skinnable interface to the
168  VLC media player. To activate the wxWindow GUI, use the `--intf wxwin'
169  flag or run the `wxvlc' program. To activate the skinnable GUI, use the
170  `--intf skins' flag.
171
172 Package: vlc-alsa
173 Architecture: any
174 Depends: vlc, vlc-plugin-alsa, ${misc:Depends}
175 Description: legacy package that you should remove
176  This package is now called vlc-plugin-alsa.
177
178 Package: vlc-esd
179 Architecture: any
180 Depends: vlc, vlc-plugin-esd, ${misc:Depends}
181 Description: legacy package that you should remove
182  This package is now called vlc-plugin-esd.
183
184 Package: vlc-ggi
185 Architecture: any
186 Depends: vlc, vlc-plugin-ggi, ${misc:Depends}
187 Description: legacy package that you should remove
188  This package is now called vlc-plugin-ggi.
189
190 Package: vlc-glide
191 Architecture: i386
192 Depends: vlc, vlc-plugin-glide, ${misc:Depends}
193 Description: legacy package that you should remove
194  This package is now called vlc-plugin-glide.
195
196 Package: vlc-gnome
197 Section: gnome
198 Architecture: any
199 Depends: vlc, gnome-vlc, ${misc:Depends}
200 Description: legacy package that you should remove
201  This package is now called gnome-vlc.
202
203 Package: vlc-gtk
204 Architecture: any
205 Depends: vlc, gvlc, ${misc:Depends}
206 Description: legacy package that you should remove
207  This package is now called gvlc.
208
209 Package: vlc-qt
210 Architecture: any
211 Depends: vlc, qvlc, ${misc:Depends}
212 Description: legacy package that you should remove
213  This package is now called qvlc.
214
215 Package: vlc-sdl
216 Architecture: any
217 Depends: vlc, vlc-plugin-sdl, ${misc:Depends}
218 Description: legacy package that you should remove
219  This package is now called vlc-plugin-sdl.
220