371100c3c723d8eb6a15f2dfc540eec4664d09d8
[vlc.git] / debian / control
1 Source: vlc
2 Section: graphics
3 Priority: optional
4 Maintainer: Samuel Hocevar <sam@zoy.org>
5 Build-Depends: debhelper (>=3.0), gettext, fortune-mod, xlibs-dev, xlibs-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libsdl1.2-dev (>=1.2.2-3.1), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>=0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi1-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, dvb-dev, libdv2-dev, libxosd-dev, svgalibg1-dev (>=1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev, libdvdplay0-dev (>=1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>=1.1.0)
6 Build-Conflicts: libmpeg2-dev, libmpeg2-0-dev, libmpeg2-1-dev, libmpeg2-2-dev, libmpeg2-3-dev
7 Standards-Version: 3.5.9.0
8
9 Package: vlc
10 Section: graphics
11 Architecture: any
12 Depends: ${shlibs:Depends}
13 Recommends: vlc-gui
14 Suggests: gnome-vlc
15 Replaces: vlc-plugin-dvb (<< 0.5.2-2), vlc-plugin-xosd (<< 0.5.2-2), vlc-plugin-dv (<< 0.5.2-2), vlc-plugin-mad (<< 0.5.2-2), vlc-mad (<< 0.5.0), vlc-plugin-a52 (<< 0.5.2-2), vlc-plugin-ogg (<< 0.5.2-2), vlc-plugin-lirc (<< 0.5.2-2), vlc-lirc (<< 0.5.0), vlc-plugin-aa (<< 0.5.2-2), vlc-aa (<< 0.5.0)
16 Conflicts: vlc-plugin-dvb (<< 0.5.2-2), vlc-plugin-xosd (<< 0.5.2-2), vlc-plugin-dv (<< 0.5.2-2), vlc-plugin-mad (<< 0.5.2-2), vlc-mad (<< 0.5.0), vlc-plugin-a52 (<< 0.5.2-2), vlc-plugin-ogg (<< 0.5.2-2), vlc-plugin-lirc (<< 0.5.2-2), vlc-lirc (<< 0.5.0), vlc-plugin-aa (<< 0.5.2-2), vlc-aa (<< 0.5.0)
17 Provides: mp3-decoder
18 Description: a complete multimedia player
19  This is the VideoLAN project's VLC media player. It plays MPEG, MPEG2,
20  MPEG4, DivX, mp3, Ogg/Vorbis files, DVDs, VCDs, and multimedia streams
21  from various network sources.
22
23 Package: libvlc0-dev
24 Section: libdevel
25 Architecture: any
26 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
27 Description: development files for VLC
28  This package contains headers and a static library required to build plugins
29  for VLC, or standalone applications that use VLC features.
30
31 Package: gnome-vlc
32 Section: gnome
33 Architecture: any
34 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
35 Recommends: vlc-plugin-esd
36 Conflicts: vlc-gnome (<< 0.5.0)
37 Replaces: vlc-gnome (<< 0.5.0)
38 Provides: vlc-gui
39 Description: GNOME frontend for VLC
40  This plugin adds a GNOME interface to the VLC media player. To activate
41  it, use the `--intf gnome' flag or run the `gnome-vlc' program.
42
43 Package: vlc-gnome
44 Section: gnome
45 Architecture: any
46 Depends: vlc, gnome-vlc
47 Description: legacy package that you should remove
48  This package is now called gnome-vlc.
49
50 Package: gvlc
51 Architecture: any
52 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
53 Conflicts: vlc-gnome (<= 0.2.63-2), vlc-gtk (<< 0.5.0)
54 Replaces: vlc-gnome (<= 0.2.63-2), vlc-gtk (<< 0.5.0)
55 Provides: vlc-gui
56 Description: GTK+ frontend for VLC
57  This plugin adds a GTK+ interface to the VLC media player. To activate
58  it, use the `--intf gtk' flag or run the `gvlc' program.
59
60 Package: vlc-gtk
61 Architecture: any
62 Depends: vlc, gvlc
63 Description: legacy package that you should remove
64  This package is now called gvlc.
65
66 Package: vlc-plugin-esd
67 Architecture: any
68 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
69 Conflicts: vlc-esd (<< 0.5.0)
70 Replaces: vlc-esd (<< 0.5.0)
71 Description: Esound audio output plugin for VLC
72  This plugin adds support for the Enlightened Sound Daemon to the VLC
73  media player. To activate it, use the `--aout esd' flag or select the
74  `esd' audio output plugin from the preferences menu.
75
76 Package: vlc-esd
77 Architecture: any
78 Depends: vlc, vlc-plugin-esd
79 Description: legacy package that you should remove
80  This package is now called vlc-plugin-esd.
81
82 Package: vlc-plugin-alsa
83 Architecture: any
84 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
85 Conflicts: vlc-alsa (<< 0.5.0)
86 Replaces: vlc-alsa (<< 0.5.0)
87 Description: ALSA audio output plugin for VLC
88  This plugin adds support for the Advanced Linux Sound Architecture to
89  the VLC media player. To activate it, use the `--aout alsa' flag or
90  select the `alsa' audio output plugin from the preferences menu.
91
92 Package: vlc-alsa
93 Architecture: any
94 Depends: vlc, vlc-plugin-alsa
95 Description: legacy package that you should remove
96  This package is now called vlc-plugin-alsa.
97
98 Package: vlc-plugin-sdl
99 Architecture: any
100 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
101 Conflicts: vlc-sdl (<< 0.5.0)
102 Replaces: vlc-sdl (<< 0.5.0)
103 Description: SDL video and audio output plugin for VLC
104  This plugin adds support for the Simple DirectMedia Layer library to
105  the VLC media player. To activate it, use the `--vout sdl' or
106  `--aout sdl' flags or select the `sdl' video or audio output plugin
107  from the preferences menu.
108
109 Package: vlc-sdl
110 Architecture: any
111 Depends: vlc, vlc-plugin-sdl
112 Description: legacy package that you should remove
113  This package is now called vlc-plugin-sdl.
114
115 Package: vlc-plugin-ggi
116 Architecture: any
117 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
118 Conflicts: vlc-ggi (<< 0.5.0)
119 Replaces: vlc-ggi (<< 0.5.0)
120 Description: GGI video output plugin for VLC
121  This is a GGI plugin for the VLC media player.  To activate it, use
122  the `--vout ggi' flag or select the `ggi' video output plugin from the
123  preferences menu.
124
125 Package: vlc-ggi
126 Architecture: any
127 Depends: vlc, vlc-plugin-ggi
128 Description: legacy package that you should remove
129  This package is now called vlc-plugin-ggi.
130
131 Package: vlc-plugin-glide
132 Architecture: i386
133 Depends: vlc (= ${Source-Version}), libglide2
134 Conflicts: vlc-glide (<< 0.5.0)
135 Replaces: vlc-glide (<< 0.5.0)
136 Description: Glide video output plugin for VLC
137  This is a Glide (3dfx) plugin for the VLC media player. To activate
138  it, use the `--vout glide' flag or select the `glide' video output
139  plugin from the preferences menu.
140
141 Package: vlc-glide
142 Architecture: i386
143 Depends: vlc, vlc-plugin-glide
144 Description: legacy package that you should remove
145  This package is now called vlc-plugin-glide.
146
147 Package: qvlc
148 Architecture: any
149 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
150 Conflicts: vlc-qt (<< 0.5.0)
151 Replaces: vlc-qt (<< 0.5.0)
152 Provides: vlc-gui
153 Description: Qt frontend for VLC
154  This plugin adds a Qt interface to the VLC media player. To activate it,
155  use the `--intf qt' flag or run the `qvlc' program.
156
157 Package: vlc-qt
158 Architecture: any
159 Depends: vlc, qvlc
160 Description: legacy package that you should remove
161  This package is now called qvlc.
162
163 Package: vlc-plugin-arts
164 Architecture: any
165 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
166 Conflicts: vlc-arts (<< 0.5.0)
167 Replaces: vlc-arts (<< 0.5.0)
168 Description: aRts audio output plugin for VLC
169  This plugin adds support for the aRts Sound System to the VLC media
170  player. To activate it, use the `--aout arts' flag or select the `arts'
171  audio output plugin from the preferences menu.
172
173 Package: mozilla-plugin-vlc
174 Architecture: any
175 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
176 Recommends: mozilla-browser
177 Description: a multimedia plugin for Mozilla based on VLC
178  This plugin adds support for MPEG, MPEG2, DVD, DivX, Ogg/Vorbis and many
179  more formats to your Mozilla browser. The decoding process is done by VLC
180  and the output window is embedded in a webpage or directly in the browser
181  window. There is also support for fullscreen display and javascript control.
182
183 Package: kvlc
184 Section: kde
185 Architecture: any
186 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
187 Recommends: vlc-plugin-arts
188 Conflicts: vlc-kde (<< 0.5.0)
189 Replaces: vlc-kde (<< 0.5.0)
190 Provides: vlc-gui
191 Description: KDE frontend for VLC
192  This plugin adds a KDE interface to the VLC media player. To activate it,
193  use the `--intf kde' flag or run the `kvlc' program.
194
195 Package: vlc-plugin-svgalib
196 Architecture: i386
197 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
198 Description: SVGAlib video output plugin for VLC
199  This plugin adds support for SVGAlib to the VLC media player. To
200  activate it, use the `--vout svgalib' flag or select the `svgalib' video
201  output plugin from the preferences menu. Note that you will need root
202  permissions to use SVGAlib.
203
204 Package: wxvlc
205 Architecture: any
206 Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
207 Provides: vlc-gui
208 Description: wxWindows frontend for VLC
209  This plugin adds a wxWindow interface to the VLC media player. To
210  activate it, use the `--intf wxwin' flag or run the `wxvlc' program.
211