contrib/gpg-error: fix compilation for embedded 64bit Darwin platforms
[vlc.git] / contrib / src / gpg-error / rules.mak
1 # GPGERROR
2 GPGERROR_VERSION := 1.13
3 GPGERROR_URL := ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-$(GPGERROR_VERSION).tar.bz2
4
5 $(TARBALLS)/libgpg-error-$(GPGERROR_VERSION).tar.bz2:
6         $(call download,$(GPGERROR_URL))
7
8 .sum-gpg-error: libgpg-error-$(GPGERROR_VERSION).tar.bz2
9
10 libgpg-error: libgpg-error-$(GPGERROR_VERSION).tar.bz2 .sum-gpg-error
11         $(UNPACK)
12 ifdef HAVE_WIN32
13         $(APPLY) $(SRC)/gpg-error/windres-make.patch
14 endif
15         $(APPLY) $(SRC)/gpg-error/missing-unistd-include.patch
16         $(MOVE)
17         cp $@/src/syscfg/lock-obj-pub.arm-unknown-linux-androideabi.h $@/src/syscfg/lock-obj-pub.linux-android.h
18 ifdef HAVE_IOS
19         cp $@/src/syscfg/lock-obj-pub.arm-unknown-linux-androideabi.h $@/src/syscfg/lock-obj-pub.$(HOST).h
20 endif
21
22 .gpg-error: libgpg-error
23         cd $< && $(HOSTVARS) ./configure $(HOSTCONF) --disable-nls --disable-shared --disable-languages
24         cd $< && $(MAKE) install
25         touch $@