doc/decoders: mention that some libdav1d options are deprecated