configure: warn if GCC 4.2 is being used