configure: Detect newer (>=4.1) versions of MinGW32