vp8: fix signed overflows