configure: Drop support for legacy PGI compiler