Add a --enable-nonfree command line parameter similar to --enable-gpl.