Give parameters of do_hybrid_window() more meaningful names
[ffmpeg.git] / libavcodec / ra288.c
2008-07-24 Vitor SessakGive parameters of do_hybrid_window() more meaningful...
2008-07-24 Vitor SessakRename co() function to the much more descriptive name of
2008-07-24 Vitor SessakSimplify co(): write constant in a more readable way
2008-07-24 Vitor SessakSimplify co(), use memcpy/memmove and colmult() when...
2008-07-19 Vitor SessakCosmetics: alignment
2008-07-19 Vitor SessakSimplify co(): do not abuse pointer aritmetics
2008-07-19 Vitor SessakSimplify co(): remove variables that are only used...
2008-07-17 Vitor SessakSimplify: do not overuse pointer aritmetic
2008-07-17 Vitor SessakDeclare parameters of pred() that could be const as...
2008-07-17 Vitor SessakAnother simplification
2008-07-17 Vitor SessakSimplify
2008-07-17 Vitor SessakSimplify
2008-07-17 Vitor SessakDeclare function parameters as const
2008-07-14 Vitor SessakRevert r14218. FFMAX is a macro, so
2008-07-13 Vitor SessakSimplify
2008-07-13 Vitor SessakAnother av_clipf() usage
2008-07-13 Vitor SessakDo not declare as double a var that only stores a float
2008-07-13 Vitor SessakSimplify: use FFMAX
2008-07-13 Vitor SessakAdd av_clipf() function to common.h and use it in ra288.c
2008-07-06 Vitor SessakSimplify: glob->phase is always == 3
2008-07-06 Vitor SessakRemove phasep context var, it is just phase*5
2008-07-06 Vitor SessakSlighly faster operation
2008-07-06 Vitor SessakCosmetics: remove braces
2008-07-06 Vitor SessakAnother use of scalar_product_float()
2008-07-06 Vitor SessakDo not reimplement memmove()
2008-07-05 Vitor SessakCosmetics: remove braces
2008-07-05 Vitor SessakCreate a function for float dot product instead of...
2008-07-04 Vitor SessakWrite for loops in a more standard way. In my opinion...
2008-07-04 Vitor SessakMove vars declaration to inner loop when possible
2008-07-04 Vitor SessakSimplify
2008-07-03 Vitor SessakRemove unneeded var
2008-07-03 Vitor SessakUse a matrix instead of a vector
2008-06-30 Vitor SessakRemove useless wrapper around ra288_decode_frame()
2008-06-30 Vitor SessakRemove unpack() function, read the bitstream as needed
2008-06-30 Vitor SessakClean up error message
2008-06-30 Vitor SessakRewrite unpack() using the bitstream reader
2008-06-30 Vitor SessakMove function to avoid forward declaration
2008-06-30 Vitor SessakRemove useless initialization
2008-06-30 Vitor SessakReindent the whole file
2008-06-12 Stefano SabatiniMake AVCodec long_names definition conditional dependin...
2008-04-27 Stefano SabatiniAdd long names to AVCodec declarations.
2008-02-01 Michael Niedermayerconst
2006-10-07 Diego BiurrunChange license headers to say 'FFmpeg' instead of ...
2006-01-12 Diego BiurrunUpdate licensing information: The FSF changed postal...
2005-12-22 Diego BiurrunCOSMETICS: tabs --> spaces, some prettyprinting
2005-12-17 Diego BiurrunCOSMETICS: Remove all trailing whitespace.
2005-12-09 Benjamin LarssonCook compatibe decoder, patch by Benjamin Larsson
2004-10-06 Zdenek Kabelac* fixing a few of gcc 'clean-code' warnings
2004-05-18 Michael Niedermayersome of the warning fixes by (Michael Roitzsch <mroi...
2003-11-03 Michel Bardiauxav_log() patch by (Michel Bardiaux <mbardiaux at peakti...
2003-08-24 Fabrice Bellardremoved unused variables
2003-06-29 Alex Beregszaszimoved the tables into header files (and applied the...
2003-06-18 Nick Kurshevoptimization: merge phases 0 and 1
2003-06-17 Nick Kurshevto be more precise
2003-06-17 Nick Kurshevfinally works now
2003-06-16 Nick Kurshevsome useful warning
2003-06-13 Zdenek Kabelac* removed redundant includes (they were even wrongly...
2003-06-13 Nick KurshevRealAudio 1.0 (14_4) and 2.0 (28_8) native decoders...