configure: Detect newer (>=4.1) versions of MinGW32
authorDiego Biurrun <diego@biurrun.de>
Wed, 11 Dec 2013 23:34:43 +0000 (00:34 +0100)
committerDiego Biurrun <diego@biurrun.de>
Fri, 13 Dec 2013 15:47:49 +0000 (16:47 +0100)
The MinGW32 project is deprecating its old version macros.

configure

index ea3d8ca..40d12e2 100755 (executable)
--- a/configure
+++ b/configure
@@ -3416,7 +3416,8 @@ probe_libc(){
     elif check_${pfx}cpp_condition _mingw.h "defined __MINGW64_VERSION_MAJOR"; then
         eval ${pfx}libc_type=mingw64
         add_${pfx}cppflags -U__STRICT_ANSI__ -D__USE_MINGW_ANSI_STDIO=1
     elif check_${pfx}cpp_condition _mingw.h "defined __MINGW64_VERSION_MAJOR"; then
         eval ${pfx}libc_type=mingw64
         add_${pfx}cppflags -U__STRICT_ANSI__ -D__USE_MINGW_ANSI_STDIO=1
-    elif check_${pfx}cpp_condition _mingw.h "defined __MINGW32_VERSION"; then
+    elif check_${pfx}cpp_condition _mingw.h "defined __MINGW_VERSION"  ||
+         check_${pfx}cpp_condition _mingw.h "defined __MINGW32_VERSION"; then
         eval ${pfx}libc_type=mingw32
         check_${pfx}cpp_condition _mingw.h "__MINGW32_MAJOR_VERSION > 3 || \
             (__MINGW32_MAJOR_VERSION == 3 && __MINGW32_MINOR_VERSION >= 15)" ||
         eval ${pfx}libc_type=mingw32
         check_${pfx}cpp_condition _mingw.h "__MINGW32_MAJOR_VERSION > 3 || \
             (__MINGW32_MAJOR_VERSION == 3 && __MINGW32_MINOR_VERSION >= 15)" ||