Fix windows build (undefined reference to gpg_error_*)
authorGeoffroy Couprie <geal@videolan.org>
Mon, 12 Oct 2009 18:02:02 +0000 (20:02 +0200)
committerGeoffroy Couprie <geal@videolan.org>
Mon, 12 Oct 2009 18:02:36 +0000 (20:02 +0200)
configure.ac

index 96ac1b0..c350c6d 100644 (file)
@@ -4679,7 +4679,7 @@ then
   then
     AC_MSG_ERROR([libgcrypt is required for update checking system])
   fi
-  VLC_ADD_LIBS([libvlccore], [${GCRYPT_LIBS}])
+  VLC_ADD_LIBS([libvlccore], [${GCRYPT_LIBS} -lgpg-error])
   VLC_ADD_CFLAGS([libvlccore], [${GCRYPT_CFLAGS}])
   AC_DEFINE([UPDATE_CHECK], 1, [Define if you want to use the VLC update mechanism])
 fi