Allow buggy glibc if Native Language Support _and_ Mozilla are off.
authorRémi Denis-Courmont <remi@remlab.net>
Sat, 25 Apr 2009 20:39:04 +0000 (23:39 +0300)
committerRémi Denis-Courmont <remi@remlab.net>
Sat, 25 Apr 2009 20:43:12 +0000 (23:43 +0300)
configure.ac

index a9711f4..08b7893 100644 (file)
@@ -554,7 +554,12 @@ AC_PREPROC_IFELSE([
   AC_MSG_RESULT([not present])
 ], [
   AC_MSG_RESULT([found])
-  AC_MSG_ERROR([Buggy GNU/libc (version 2.5 - 2.7) present. VLC would crash; there is no viable work-around for this. Check with your distribution vendor on how to update the glibc run-time.])
+  AS_IF([test "x${enable_nls}" != "xno" || test "x${enable_mozilla}" != "xno"], [
+    AC_MSG_ERROR([Buggy GNU/libc (version 2.5 - 2.7) present. VLC would crash; there is no viable
+work-around for this. Check with your distribution vendor on how to update the
+glibc run-time. Alternatively, build with --disable-nls --disable-mozilla and
+be sure to not use LibVLC from other applications/wrappers.])
+  ])
 ])
 
 dnl Plugin compilation stuff