Link plugins against libvlccore
authorRémi Denis-Courmont <rdenis@simphalempin.com>
Sat, 14 Feb 2009 12:01:34 +0000 (14:01 +0200)
committerRémi Denis-Courmont <rdenis@simphalempin.com>
Sat, 14 Feb 2009 18:02:30 +0000 (20:02 +0200)
This reverts back to 0.9 (and --enable-libtool 0.8.6) state. This
should fix bindings and web plugins, without hacks. However, this will
require relinking all VLC plugins whenever libvlccore changes.

modules/common.am

index 4139862..caa5659 100644 (file)
@@ -21,18 +21,9 @@ AM_LDFLAGS = -rpath '$(libvlcdir)' \
        -avoid-version -module \
        -export-symbol-regex ^vlc_entry \
        -shrext $(LIBEXT) \
+       -no-undefined \
         `$(VLC_CONFIG) --ldflags plugin $@`
-AM_LIBADD = `$(VLC_CONFIG) -libs plugin $@`
-if HAVE_WIN32
-# Windows does not support undefined symbols
-AM_LDFLAGS += -no-undefined
-AM_LIBADD += $(LTLIBVLCCORE)
-endif
-if HAVE_WINCE
-# Same for Windows CE
-AM_LDFLAGS += -no-undefined
-AM_LIBADD += $(LTLIBVLCCORE)
-endif
+AM_LIBADD = `$(VLC_CONFIG) -libs plugin $@` $(LTLIBVLCCORE)
 
 include $(srcdir)/Modules.am