RAOP needs gpg-error as it calls gpg_strerror()
authorRémi Denis-Courmont <remi@remlab.net>
Sat, 25 Apr 2009 15:18:12 +0000 (18:18 +0300)
committerRémi Denis-Courmont <remi@remlab.net>
Sat, 25 Apr 2009 19:10:35 +0000 (22:10 +0300)
configure.ac

index a205f90..a9711f4 100644 (file)
@@ -5439,7 +5439,7 @@ AC_MSG_CHECKING([whether to enable RAOP plugin])
 AS_IF([test "${have_libgcrypt}" = "yes"], [
   AC_MSG_RESULT(yes)
   VLC_ADD_PLUGIN([stream_out_raop])
-  VLC_ADD_LIBS([stream_out_raop], [${LIBGCRYPT_LIBS}])
+  VLC_ADD_LIBS([stream_out_raop], [${LIBGCRYPT_LIBS} -lgpg-error])
   VLC_ADD_CFLAGS([stream_out_raop], [${LIBGCRYPT_CFLAGS}])
 ], [
   AC_MSG_RESULT(no)