Bump necessary Qt version to 4.4
authorJean-Baptiste Kempf <jb@videolan.org>
Thu, 14 May 2009 17:34:36 +0000 (19:34 +0200)
committerJean-Baptiste Kempf <jb@videolan.org>
Thu, 14 May 2009 17:35:56 +0000 (19:35 +0200)
configure.ac
modules/gui/qt4/qt4.hpp

index 75992a1..c7533a9 100644 (file)
@@ -4941,7 +4941,7 @@ then
     VLC_ADD_LIBS([maemo],[${HILDON_LIBS}])
     VLC_ADD_PLUGIN([maemo])
     VLC_ADD_PLUGIN([swscale_maemo])
-    AC_DEFINE([BUILD_MAEMO], 1, [Define if you're using Maemo interfaces])
+    AC_DEFINE([BUILD_MAEMO], 1, [Define if you are using Maemo interfaces])
     ALIASES="${ALIASES} mvlc"
   ], [
     AS_IF([test "${enable_maemo}" = "yes"],[
@@ -4960,7 +4960,7 @@ AC_ARG_ENABLE(qt4,
   AS_IF([test "${SYS}" = "darwin"], [enable_qt4=no])
 ])
 AS_IF([test "${enable_qt4}" != "no"], [
-  PKG_CHECK_MODULES(QT4, [QtCore QtGui >= 4.3.0], [
+  PKG_CHECK_MODULES(QT4, [QtCore QtGui >= 4.4.2], [
     VLC_ADD_PLUGIN([qt4])
     AC_DEFINE([HAVE_QT4], 1, [Define to 1 if you have QT4 library.])
     ALIASES="${ALIASES} qvlc"
index dbcd04f..6bde271 100644 (file)
@@ -36,7 +36,7 @@
 #include <QEvent>
 #include <QString>
 
-#if ( QT_VERSION < 0x040300 )
+#if ( QT_VERSION < 0x040400 )
 # error Update your Qt version
 #endif
 #if QT_VERSION == 0x040500