Disable glibc runtime check if configure passed due to disable-{nls, mozilla}
authorDavid Flynn <davidf@rd.bbc.co.uk>
Thu, 7 May 2009 12:47:35 +0000 (12:47 +0000)
committerRémi Denis-Courmont <remi@remlab.net>
Thu, 7 May 2009 15:36:29 +0000 (18:36 +0300)
Signed-off-by: David Flynn <davidf@rd.bbc.co.uk>
Signed-off-by: Rémi Denis-Courmont <remi@remlab.net>
configure.ac
src/misc/linux_specific.c

index 7328ccf..36e9840 100644 (file)
@@ -559,6 +559,8 @@ AC_PREPROC_IFELSE([
 work-around for this. Check with your distribution vendor on how to update the
 glibc run-time. Alternatively, build with --disable-nls --disable-mozilla and
 be sure to not use LibVLC from other applications/wrappers.])
+  ], [
+    AC_DEFINE(DISABLE_BUGGY_GLIBC_CHECK, 1, [Disables runtime check for buggy glibc.])
   ])
 ])
 
index a9165c1..79c8807 100644 (file)
@@ -90,7 +90,9 @@ void system_Init (libvlc_int_t *libvlc, int *argc, const char *argv[])
         fputs ("LibVLC has detected an unusable buggy GNU/libc version.\n"
                "Please update to version 2.8 or newer.\n", stderr);
         fflush (stderr);
+#ifndef DISABLE_BUGGY_GLIBC_CHECK
         abort ();
+#endif
     }
 #endif