Revert "Fix windows build (undefined reference to gpg_error_*)"
authorRémi Denis-Courmont <remi@remlab.net>
Mon, 12 Oct 2009 18:07:20 +0000 (21:07 +0300)
committerRémi Denis-Courmont <remi@remlab.net>
Mon, 12 Oct 2009 18:07:20 +0000 (21:07 +0300)
LibVLC is not calling gpg_error functions anywhere. Linking gpg-error
causes problems with *correctly* built libgcrypt (e.g. incorrect
package dependencies).

This reverts commit f865a8169457c8fa934782974e1b21c534bf0744.

configure.ac

index c350c6d..96ac1b0 100644 (file)
@@ -4679,7 +4679,7 @@ then
   then
     AC_MSG_ERROR([libgcrypt is required for update checking system])
   fi
-  VLC_ADD_LIBS([libvlccore], [${GCRYPT_LIBS} -lgpg-error])
+  VLC_ADD_LIBS([libvlccore], [${GCRYPT_LIBS}])
   VLC_ADD_CFLAGS([libvlccore], [${GCRYPT_CFLAGS}])
   AC_DEFINE([UPDATE_CHECK], 1, [Define if you want to use the VLC update mechanism])
 fi