Added stream output. (common work with titer).
[vlc.git] / INSTALL.libmad
1 INSTALL file for libmad, an integer based MPEG 1,2,3 audio decoder library
2
3
4 The mad plugin/builtin of VideoLan Client (vlc) uses an external library called libmad.
5
6 Before compiling mad support into vlc the library must be installed first. The following
7 text will explain howto compile and install libmad and mad plugin/builtin.
8
9
10 Where to find libmad
11 =====================
12
13 Libmad can be found at: http://www.mars.org/home/rob/proj/mpeg/
14 and is part of the mad distribution.
15
16
17 Configuring libmad
18 =====================
19
20 Goto to the libmad subdirectory and run configure..
21
22 A typical way to configure libmad as static library is:
23
24    ./configure --prefix=/usr --enable-static
25
26 A typical way to configure libmad as shared library is:
27
28    ./configure --prefix=/usr --enable-shared
29
30 See `./configure --help' for more information.
31
32
33 Building libmad
34 ==================
35
36 Once configured, run `make' to build libmad.
37
38
39 Installing libmad
40 ====================
41
42 You can install libmad as root by typing:
43
44    make install
45
46 Libmad will be installed into the directory used at the configure stage.
47 In our example this is /usr (libaries will go in /usr/lib/, include files
48 will go in /usr/include).
49
50
51 Configuring mad plugin
52 =========================
53
54 If libmad is installed in /usr (ie. you have /usr/include/mad.h and /usr/lib/libmad.a),
55 then you just need --enable-mad --with-mad=/usr.
56
57    make distclean; ./configure --prefix=/usr --enable-fb --enable-dsp --disable-sdl \
58         --enable-x11 --disable-xvideo --enable-mad --with-mad=/usr
59
60 If sdl source code is installed, then --enable-sdl can also be used.    
61         
62    make distclean; ./configure --prefix=/usr --enable-fb --enable-dsp --disable-sdl \
63         --enable-x11 --enable-xvideo --enable-mad --with-mad=/usr
64
65         
66 Building mad plugin
67 =====================
68
69 Once configured, run `make' to build vlc with mad support.
70
71
72 Installing mad
73 ==================
74
75 You can install vlc as root by typing:
76
77    make install
78
79