configure: Remove --enable-incompatible-libav-abi from the help output