configure: check rubberband version, allow only latest one
authorPaul B Mahol <onemda@gmail.com>
Thu, 1 Oct 2015 20:30:18 +0000 (22:30 +0200)
committerPaul B Mahol <onemda@gmail.com>
Thu, 1 Oct 2015 20:30:18 +0000 (22:30 +0200)
Signed-off-by: Paul B Mahol <onemda@gmail.com>
configure

index 361c024..552f698 100755 (executable)
--- a/configure
+++ b/configure
@@ -5289,7 +5289,7 @@ enabled libopus           && require_pkg_config opus opus_multistream.h opus_mul
 enabled libpulse          && require_pkg_config libpulse pulse/pulseaudio.h pa_context_new
 enabled libquvi           && require_pkg_config libquvi quvi/quvi.h quvi_init
 enabled librtmp           && require_pkg_config librtmp librtmp/rtmp.h RTMP_Socket
-enabled librubberband     && require_pkg_config rubberband rubberband/rubberband-c.h rubberband_new
+enabled librubberband     && require_pkg_config "rubberband >= 1.8.1" rubberband/rubberband-c.h rubberband_new
 enabled libschroedinger   && require_pkg_config schroedinger-1.0 schroedinger/schro.h schro_init
 enabled libshine          && require_pkg_config shine shine/layer3.h shine_encode_buffer
 enabled libsmbclient      && { use_pkg_config smbclient libsmbclient.h smbc_init ||