avcodec/nvdec: Fix capability check with old drivers.
authorJacob Trimble <modmaker-at-google.com@ffmpeg.org>
Thu, 30 Nov 2017 20:35:50 +0000 (12:35 -0800)
committerTimo Rothenpieler <timo@rothenpieler.org>
Fri, 8 Dec 2017 16:56:38 +0000 (17:56 +0100)
commit2fdc9f7c4939f83a6c9d1f9d85b6d37ce0bab714
treeae86015d16e2f3fd14f86a862168d61c5af0b5e2
parentbc38c8f4424982617a92d1cefa7fdcb640a80234
avcodec/nvdec: Fix capability check with old drivers.

Copied the check from cuviddec.c (*_cuvid decoders) to allow the
capability check to be optional for older drivers.

Signed-off-by: Jacob Trimble <modmaker@google.com>
Signed-off-by: Timo Rothenpieler <timo@rothenpieler.org>
libavcodec/nvdec.c