Improve yasm version check
authorAnton Mitrofanov <BugMaster@narod.ru>
Sat, 22 Oct 2011 15:41:07 +0000 (19:41 +0400)
committerJason Garrett-Glaser <jason@x264.com>
Sun, 23 Oct 2011 21:51:33 +0000 (14:51 -0700)
Previous check allowed certain earlier versions that weren't fully compatible.

configure

index de6afd9..a371cae 100755 (executable)
--- a/configure
+++ b/configure
@@ -631,7 +631,7 @@ if [ $shared = yes -a \( $ARCH = "X86_64" -o $ARCH = "PPC" -o $ARCH = "ALPHA" -o
 fi
 
 if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \) ] ; then
-    if ! as_check "vfmaddps xmm0, xmm0, xmm0, xmm0" ; then
+    if ! as_check "vpperm xmm0, xmm0, xmm0, xmm0" ; then
         VER=`($AS --version || echo no assembler) 2>/dev/null | head -n 1`
         echo "Found $VER"
         echo "Minimum version is yasm-1.0.0"