Get rid of ligcrypt M4 macros
authorRémi Denis-Courmont <remi@remlab.net>
Tue, 6 Oct 2009 19:23:42 +0000 (22:23 +0300)
committerRémi Denis-Courmont <remi@remlab.net>
Tue, 6 Oct 2009 19:44:53 +0000 (22:44 +0300)
One day maybe, the gcrypt maintainer will get a clue, realize
that his library is not the center of the universe,
that his crappy macros breaks cross-compiling,
that pkg-config works on Windows as well as scripts (ligcrypt-config),
and accept the Debian .pc patches.

Until then...

HACKING
Makefile.am
configure.ac
libs/srtp/Makefile.am
modules/access/rtp/Modules.am
modules/stream_out/Modules.am

diff --git a/HACKING b/HACKING
index 804a186..0270003 100644 (file)
--- a/HACKING
+++ b/HACKING
@@ -18,7 +18,6 @@ You will need the following tools if you plan to use the GIT version of vlc:
  - Automake version 1.9 or later
  - gettext version 0.16.1 or later
  - pkg-config
- - libgcrypt 1.2 (or compatible)
 
 After retrieving the GIT tree, you need to run the bootstrap script to
 generate all the files needed to build vlc. You can then run configure.
index e85fd4a..4d16422 100644 (file)
@@ -23,7 +23,7 @@ SUBDIRS = po compat src
 if LOADER
 SUBDIRS += libs/loader
 endif
-if HAVE_LIBGCRYPT
+if HAVE_GCRYPT
 SUBDIRS += libs/srtp
 endif
 if HAVE_ZLIB
index 09f0dee..29adb16 100644 (file)
@@ -4588,16 +4588,27 @@ dnl
 dnl libgcrypt
 dnl
 AC_ARG_ENABLE(libgcrypt,
-  [  --disable-libgcrypt      libgcrypts support (default enabled)])
+  [  --disable-libgcrypt      gcrypt support (default enabled)])
 AS_IF([test "${enable_libgcrypt}" != "no"], [
-  AM_PATH_LIBGCRYPT([1:1.1.94], [have_libgcrypt="yes"], [have_libgcrypt="no"])
+  AC_CHECK_DECL([GCRYCTL_SET_THREAD_CBS], [
+    have_libgcrypt="yes"
+    GCRYPT_CFLAGS=""
+    GCRYPT_LIBS="-lgcrypt"
+  ], [
+    AS_IF([test "${enable_libgcrypt}"], [
+      AC_MSG_ERROR([libgcrypt version 1.1.94 or higher not found.])
+    ])
+    have_libgcrypt="no"
+  ], [#include <gcrypt.h>])
 ])
 if test "${SYS}" = "mingw32" -o "${SYS}" = "mingwce"; then
   AS_IF([test "${have_libgcrypt}" = "yes"],[
-    VLC_ADD_LIBS([rtp stream_out_rtp], [${LIBGCRYPT_LIBS}])
+    VLC_ADD_LIBS([rtp stream_out_rtp], [${GCRYPT_LIBS}])
   ])
 fi
-AM_CONDITIONAL([HAVE_LIBGCRYPT], [test "${have_libgcrypt}" = "yes"])
+AC_SUBST(GCRYPT_CFLAGS)
+AC_SUBST(GCRYPT_LIBS)
+AM_CONDITIONAL([HAVE_GCRYPT], [test "${have_libgcrypt}" = "yes"])
 
 dnl
 dnl TLS/SSL
@@ -4616,8 +4627,8 @@ AS_IF([test "${enable_gnutls}" != "no"], [
     ])
     dnl The GnuTLS plugin invokes gcry_control directly.
     AS_IF([test "${have_libgcrypt}" = "yes"],[
-      VLC_ADD_LIBS([gnutls], [${LIBGCRYPT_LIBS}])
-      VLC_ADD_CFLAGS([gnutls], [${LIBGCRYPT_CFLAGS}])
+      VLC_ADD_LIBS([gnutls], [${GCRYPT_LIBS}])
+      VLC_ADD_CFLAGS([gnutls], [${GCRYPT_CFLAGS}])
     ])
     VLC_ADD_LIBS([gnutls], [$GNUTLS_LIBS])
   ], [
@@ -4637,8 +4648,8 @@ AC_ARG_ENABLE(remoteosd,
 AS_IF([test "${enable_remoteosd}" != "no"], [
   AS_IF([test "${have_libgcrypt}" = "yes"],[
     VLC_ADD_PLUGIN([remoteosd])
-    VLC_ADD_LIBS([remoteosd], ${LIBGCRYPT_LIBS})
-    VLC_ADD_CFLAGS([remoteosd], ${LIBGCRYPT_CFLAGS})
+    VLC_ADD_LIBS([remoteosd], ${GCRYPT_LIBS})
+    VLC_ADD_CFLAGS([remoteosd], ${GCRYPT_CFLAGS})
   ], [
     AC_MSG_ERROR([libgcrypt support required for RemoteOSD plugin])
   ])
@@ -4652,8 +4663,8 @@ AC_MSG_CHECKING([whether to enable RAOP plugin])
 AS_IF([test "${have_libgcrypt}" = "yes"], [
   AC_MSG_RESULT(yes)
   VLC_ADD_PLUGIN([stream_out_raop])
-  VLC_ADD_LIBS([stream_out_raop], [${LIBGCRYPT_LIBS} -lgpg-error])
-  VLC_ADD_CFLAGS([stream_out_raop], [${LIBGCRYPT_CFLAGS}])
+  VLC_ADD_LIBS([stream_out_raop], [${GCRYPT_LIBS} -lgpg-error])
+  VLC_ADD_CFLAGS([stream_out_raop], [${GCRYPT_CFLAGS}])
 ], [
   AC_MSG_RESULT(no)
   AC_MSG_WARN([libgcrypt support required for RAOP plugin])
@@ -4671,8 +4682,8 @@ then
   then
     AC_MSG_ERROR([libgcrypt is required for update checking system])
   fi
-  VLC_ADD_LIBS([libvlccore], [${LIBGCRYPT_LIBS}])
-  VLC_ADD_CFLAGS([libvlccore], [${LIBGCRYPT_CFLAGS}])
+  VLC_ADD_LIBS([libvlccore], [${GCRYPT_LIBS}])
+  VLC_ADD_CFLAGS([libvlccore], [${GCRYPT_CFLAGS}])
   AC_DEFINE([UPDATE_CHECK], 1, [Define if you want to use the VLC update mechanism])
 fi
 
index cef9824..4c72aa7 100644 (file)
@@ -15,7 +15,7 @@
 # License along with this library; if not, write to the Free Software
 # Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
 
-AM_CPPFLAGS = @LIBGCRYPT_CFLAGS@
+AM_CPPFLAGS = @GCRYPT_CFLAGS@
 
 noinst_HEADERS = srtp.h
 
@@ -25,12 +25,12 @@ check_PROGRAMS = test-aes test-recv
 TESTS = $(check_PROGRAMS)
 
 libvlc_srtp_la_SOURCES = srtp.c
-libvlc_srtp_la_LIBADD = @LIBGCRYPT_LIBS@
+libvlc_srtp_la_LIBADD = @GCRYPT_LIBS@
 
 srtp_SOURCES = recv.c
 srtp_LDADD = libvlc_srtp.la
 test_recv_LDADD = libvlc_srtp.la
-test_aes_LDADD = @LIBGCRYPT_LIBS@
+test_aes_LDADD = @GCRYPT_LIBS@
 
 if !HAVE_WIN32
 libvlc_srtp_la_LIBADD += -lpthread
index 855ca56..d00da33 100644 (file)
@@ -1,4 +1,4 @@
-if HAVE_LIBGCRYPT
+if HAVE_GCRYPT
 # RTP plugin
 libvlc_LTLIBRARIES += \
        librtp_plugin.la
index 36625b3..6a58cb0 100644 (file)
@@ -30,7 +30,7 @@ libvlc_LTLIBRARIES += \
        libstream_out_smem_plugin.la \
        $(NULL)
 
-if HAVE_LIBGCRYPT
+if HAVE_GCRYPT
 # RTP plugin
 libvlc_LTLIBRARIES += \
        libstream_out_rtp_plugin.la