contrib: gpg-error: apply upstream patch for gawk 5.0 support