loader doesn't use libdl (and libdl doesn't exist on FreeBSD)