dialog: use new API