Compat: relicense strsep to LGPL