configure: drop build-time libproxy dependency
authorRémi Denis-Courmont <remi@remlab.net>
Fri, 12 Apr 2013 16:24:44 +0000 (19:24 +0300)
committerRémi Denis-Courmont <remi@remlab.net>
Fri, 12 Apr 2013 16:25:39 +0000 (19:25 +0300)
Due to instability and leaks in libproxy, VLC now uses the executable
binary from libproxy-tools instead directly calling the functions.

configure.ac

index e42127e..34c0a12 100644 (file)
@@ -1586,23 +1586,6 @@ dnl
 
 EXTEND_HELP_STRING([Input plugins:])
 
-dnl
-dnl libproxy support
-dnl
-AC_ARG_ENABLE(libproxy,
-  [AS_HELP_STRING([--enable-libproxy],[support libproxy (default auto)])])
-AS_IF([test "${enable_libproxy}" != "no"], [
-  PKG_CHECK_MODULES(LIBPROXY, libproxy-1.0, [
-    AC_DEFINE(HAVE_LIBPROXY, 1, [Define if libproxy is available])
-    VLC_ADD_CFLAGS([access_http],[$LIBPROXY_CFLAGS])
-    VLC_ADD_LIBS([access_http],[$LIBPROXY_LIBS])
-  ], [
-    AS_IF([test -n "${enable_libproxy}"], [
-      AC_MSG_ERROR([${LIBPROXY_PKG_ERRORS}.])
-    ])
-  ])
-])
-
 dnl
 dnl  live555 input
 dnl