contrib/png: require at least libpng 1.5.4
authorSean McGovern <gseanmcg@gmail.com>
Sat, 15 Apr 2017 14:19:19 +0000 (10:19 -0400)
committerRémi Denis-Courmont <remi@remlab.net>
Sat, 15 Apr 2017 16:22:12 +0000 (19:22 +0300)
png_set_alpha_mode() was not introduced until this version.

Signed-off-by: Rémi Denis-Courmont <remi@remlab.net>
contrib/src/png/rules.mak

index 3bcfa77..9a05170 100644 (file)
@@ -3,7 +3,7 @@ PNG_VERSION := 1.6.29
 PNG_URL := $(SF)/libpng/libpng16/$(PNG_VERSION)/libpng-$(PNG_VERSION).tar.xz
 
 PKGS += png
-ifeq ($(call need_pkg,"libpng"),)
+ifeq ($(call need_pkg,"libpng >= 1.5.4"),)
 PKGS_FOUND += png
 endif