contrib: sparkle: Downgrade to sparkle 1.16 for now
authorDavid Fuhrmann <dfuhrmann@videolan.org>
Mon, 4 Sep 2017 21:40:39 +0000 (23:40 +0200)
committerDavid Fuhrmann <dfuhrmann@videolan.org>
Mon, 4 Sep 2017 21:45:45 +0000 (23:45 +0200)
Sparkle 1.17 added support for the new os_log API, but forgot to
correctly guard the header to allow compilation with SDKs < 10.12.
Downgrade as long as current sparkle version can only compile with
10.12 SDK.

contrib/src/sparkle/SHA512SUMS
contrib/src/sparkle/rules.mak

index 40af35f..c514685 100644 (file)
@@ -1 +1 @@
-51ef5e0b3ccfd4fd1297b0447a694339481b4dd6662f3dea20045711cac6dcc4b7b8baeae618d4c53b96fc49d02471a7fd378c3f3f88e94e8706884b1bb53ed3  Sparkle-1.18.1.zip
+5ed418c48878d4304f2d0bbdcf2e1bfafbe0cde57d4f4e294bd1e60a23dab76d86a0b5d393ed12d1d7c144e470d004a994ad76f46765bcc789d0e43035b9ab2a  Sparkle-1.16.0.zip
index dd84c4d..32591bf 100644 (file)
@@ -1,6 +1,6 @@
 # Sparkle
 
-SPARKLE_VERSION := 1.18.1
+SPARKLE_VERSION := 1.16.0
 SPARKLE_URL := https://github.com/sparkle-project/Sparkle/archive/$(SPARKLE_VERSION).zip
 
 ifdef HAVE_MACOSX