gnutls: require version 3.1.4 or later
authorRémi Denis-Courmont <remi@remlab.net>
Fri, 22 Aug 2014 20:07:07 +0000 (23:07 +0300)
committerRémi Denis-Courmont <remi@remlab.net>
Fri, 22 Aug 2014 20:34:21 +0000 (23:34 +0300)
configure.ac
modules/misc/gnutls.c

index 5be9e40..2be1237 100644 (file)
@@ -4064,7 +4064,7 @@ dnl
 AC_ARG_ENABLE(gnutls,
   [  --enable-gnutls         GNU TLS TLS/SSL support (default enabled)])
 AS_IF([test "${enable_gnutls}" != "no"], [
-  PKG_CHECK_MODULES(GNUTLS, [gnutls >= 3.0.20], [
+  PKG_CHECK_MODULES(GNUTLS, [gnutls >= 3.1.4], [
     VLC_ADD_PLUGIN([gnutls])
   ], [
     AS_IF([test -n "${enable_gnutls}"], [
index da6c0e5..c67c5f5 100644 (file)
@@ -104,7 +104,7 @@ static int gnutls_Init (vlc_object_t *p_this)
         goto error;
     }
 
-    const char *psz_version = gnutls_check_version ("3.0.20");
+    const char *psz_version = gnutls_check_version ("3.1.4");
     if (psz_version == NULL)
     {
         msg_Err (p_this, "unsupported GnuTLS version");