contribs: modplug: Do not force old minimum macosx version
authorDavid Fuhrmann <dfuhrmann@videolan.org>
Wed, 14 Aug 2019 07:23:04 +0000 (09:23 +0200)
committerHugo Beauzée-Luyssen <hugo@beauzee.fr>
Wed, 14 Aug 2019 12:03:49 +0000 (14:03 +0200)
VLC already sets the minimum version, forcing an older version
makes compilation fail with our flags.

Signed-off-by: Hugo Beauzée-Luyssen <hugo@beauzee.fr>
contrib/src/modplug/macosx-do-not-force-min-version.patch [new file with mode: 0644]
contrib/src/modplug/rules.mak

diff --git a/contrib/src/modplug/macosx-do-not-force-min-version.patch b/contrib/src/modplug/macosx-do-not-force-min-version.patch
new file mode 100644 (file)
index 0000000..ee0e63d
--- /dev/null
@@ -0,0 +1,15 @@
+--- libmodplug/configure.ac.old        2019-08-14 09:18:02.000000000 +0200
++++ libmodplug/configure.ac    2019-08-14 09:18:28.000000000 +0200
+@@ -44,12 +44,6 @@
+ esac
+ AC_SUBST(LT_LDFLAGS)
+-# require 10.5+ for osx/x86_64 builds
+-case "$host" in
+-      x86_64-*-darwin*)
+-              CXXFLAGS="$CXXFLAGS -mmacosx-version-min=10.5"
+-              LDFLAGS="$LDFLAGS -mmacosx-version-min=10.5" ;;
+-esac
+ # symbol visibility
+ ac_save_CXXFLAGS="$CXXFLAGS"
index 60a7597..61e5374 100644 (file)
@@ -16,6 +16,7 @@ $(TARBALLS)/libmodplug-$(MODPLUG_VERSION).tar.gz:
 libmodplug: libmodplug-$(MODPLUG_VERSION).tar.gz .sum-modplug
        $(UNPACK)
        $(APPLY) $(SRC)/modplug/modplug-win32-static.patch
+       $(APPLY) $(SRC)/modplug/macosx-do-not-force-min-version.patch
        $(call pkg_static,"libmodplug.pc.in")
        $(MOVE)