contrib: qt: disable direct2d
authorThomas Guillem <thomas@gllm.fr>
Thu, 11 Apr 2019 11:08:26 +0000 (13:08 +0200)
committerThomas Guillem <thomas@gllm.fr>
Thu, 11 Apr 2019 11:08:34 +0000 (13:08 +0200)
Because if fails to build with mingw64 5.x headers. We can remove this hack
once we increment the minimal mingw64 version (to 6).

Direct2d is only used for Qt Widgets and is not mandatory.

contrib/src/qt/rules.mak

index c709817..135280f 100644 (file)
@@ -85,6 +85,10 @@ QT_CONFIG := -static -opensource -confirm-license -no-pkg-config \
 
 QT_CONFIG += -release
 
+ifdef HAVE_MINGW_W64
+QT_CONFIG += -no-direct2d
+endif
+
 ENV_VARS := $(HOSTVARS) DXSDK_DIR=$(PREFIX)/bin
 
 .qt: qt