gnutls: require version 3.1.11
authorRémi Denis-Courmont <remi@remlab.net>
Sat, 23 Aug 2014 20:29:09 +0000 (23:29 +0300)
committerRémi Denis-Courmont <remi@remlab.net>
Sat, 23 Aug 2014 20:29:09 +0000 (23:29 +0300)
configure.ac
contrib/src/gnutls/rules.mak
modules/misc/gnutls.c

index c10fded..a71055e 100644 (file)
@@ -4064,7 +4064,7 @@ dnl
 AC_ARG_ENABLE(gnutls,
   [  --enable-gnutls         GNU TLS TLS/SSL support (default enabled)])
 AS_IF([test "${enable_gnutls}" != "no"], [
-  PKG_CHECK_MODULES(GNUTLS, [gnutls >= 3.1.9], [
+  PKG_CHECK_MODULES(GNUTLS, [gnutls >= 3.1.11], [
     VLC_ADD_PLUGIN([gnutls])
   ], [
     AS_IF([test -n "${enable_gnutls}"], [
index a05fb07..27497dd 100644 (file)
@@ -8,7 +8,7 @@ ifndef HAVE_DARWIN_OS
 PKGS += gnutls
 endif
 endif
-ifeq ($(call need_pkg,"gnutls >= 3.1.9"),)
+ifeq ($(call need_pkg,"gnutls >= 3.1.11"),)
 PKGS_FOUND += gnutls
 endif
 
index e9e999f..280fa5b 100644 (file)
@@ -61,7 +61,7 @@ static vlc_mutex_t gnutls_mutex = VLC_STATIC_MUTEX;
  */
 static int gnutls_Init (vlc_object_t *obj)
 {
-    const char *version = gnutls_check_version ("3.1.9");
+    const char *version = gnutls_check_version ("3.1.11");
     if (version == NULL)
     {
         msg_Err (obj, "unsupported GnuTLS version");