macosx: Make fscontroller compatible with <10.10
authorMarvin Scholz <epirat07@gmail.com>
Tue, 11 Oct 2016 08:17:30 +0000 (10:17 +0200)
committerMarvin Scholz <epirat07@gmail.com>
Sun, 30 Oct 2016 21:45:13 +0000 (22:45 +0100)
commit4abb898dab05fb324aa8df0b50a0d79c3adbe024
treeafc5a16150cf6c2ff4545f9ed86fd0d6951e42a5
parent43b089ca740e7721d968354812cc05cc65445a36
macosx: Make fscontroller compatible with <10.10

This will add a fallback mechanism that uses a
normal layer-backed NSView with a dark but still
slightly transparent background on macOS versions
that do not support NSVisualEffectView.

Additionally it will allow compilation with older
SDK's that have no NSVisualEffectView defined.
If compiled with such an SDK, support for
NSVisualEffectView is disabled completely, so
even when running the compiled VLC version
on 10.10 or higher it will use the old fallback
view, as the SDK it was compiled with had not the
necessary definitions.
modules/gui/macosx/CompatibilityFixes.h
modules/gui/macosx/VLCFSPanelController.m