rawvid: drop unused include
[vlc.git] / bootstrap
index a17fb78..f251f9e 100755 (executable)
--- a/bootstrap
+++ b/bootstrap
@@ -19,44 +19,21 @@ fi
 
 ACLOCAL_ARGS="-I m4 ${ACLOCAL_ARGS}"
 
+# Check for tools directory
+if test -d extras/tools/build/bin; then
+  PATH="`pwd`/extras/tools/build/bin:$PATH"
+fi
+
 ###
 ###  Get a sane environment, just in case
 ###
 CYGWIN=binmode
 export CYGWIN
 
-# Check for contrib directory
-if test -d extras/contrib/build/bin; then
-  PATH="`pwd`/extras/contrib/build/bin:$PATH"
-  if test -d extras/contrib/build/share/aclocal; then
-    ACLOCAL_ARGS="${ACLOCAL_ARGS} -I extras/contrib/build/share/aclocal"
-  fi
-  if test ".`uname -s`" = ".Darwin"; then
-    LD_LIBRARY_PATH=./extras/contrib/build/lib:$LD_LIBRARY_PATH
-    DYLD_LIBRARY_PATH=./extras/contrib/build/lib:$DYLD_LIBRARY_PATH
-    export LD_LIBRARY_PATH
-    export DYLD_LIBRARY_PATH
-  fi
-fi
-
-# Prepare m4/private.m4
-rm -f m4/private.m4 && cat > m4/private.m4 << EOF
-dnl  Private VLC macros - generated by bootstrap
-EOF
-
 # Check for pkg-config
-if ! pkg-config --version >/dev/null 2>&1; then
-       cat << EOF
-NOTE: "pkg-config" is missing from your system.
-Many underlying libraries will not be detected.
-==============================================================
-
-EOF
-       cat >> m4/private.m4 << EOF
-dnl  User does not have pkg-config, so assume package was not found
-AC_DEFUN([PKG_CHECK_MODULES],[ifelse([\$4], , :, [\$4])])
-
-EOF
+if ! "${PKG_CONFIG:-pkg-config}" --version >/dev/null 2>&1; then
+       echo 'Error: "pkg-config" is not installed.' >&2
+       exit 1
 fi
 
 # Check for autopoint (GNU gettext)
@@ -65,42 +42,20 @@ test "$AUTOPOINT" || AUTOPOINT=autopoint
 if ! "$AUTOPOINT" --dry-run --force >/dev/null 2>&1; then
        AUTOPOINT=true
        cat << EOF
-NOTE: GNU gettext appears to be missing or out-of-date.
-Please install or update GNU gettext.
-Also check if you have cvs, a dependency of autopoint.
+NOTE: autopoint (GNU gettext-tools) appears to be missing or out-of-date.
+Please install or update GNU gettext tools.
 Otherwise, you will not be able to build a source tarball.
-==============================================================
+==========================================================================
 
 EOF
 fi
 
-###
-### Generate the modules makefile, by parsing modules/**/Modules.am
-###
-
-echo "generating modules/**/Makefile.am"
-find modules/ -name Modules.am | \
-sed -ne 's,modules/\(.*\)/Modules.am,\1,p' | \
-while read d; do
-       sh modules/genmf "$d"
-       printf "."
-done
-printf "\n"
-
-set -x
-
 ###
 ###  classic bootstrap stuff
 ###
 
-# Automake complains if these are not present
-echo > ABOUT-NLS
-cp -f INSTALL INSTALL.git
-
 autoreconf --install --force --verbose ${ACLOCAL_ARGS}
-rm -f po/Makevars.template ABOUT-NLS
-echo > ABOUT-NLS
-mv -f INSTALL.git INSTALL
+rm -f po/Makevars.template
 
 ##
 ##  files which need to be regenerated