spu: remove useless check
[vlc.git] / INSTALL
diff --git a/INSTALL b/INSTALL
index 0b42328..6cc57b9 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -1,42 +1,64 @@
-INSTALL file for vlc, the VideoLAN Client
+INSTALL file for the VLC media player
+=====================================
 
+More extensive information for *nix, Windows and Mac OS X users can be
+found here: http://wiki.videolan.org/Compile_VLC
 
-Building VideoLAN
+People installing VLC for Windows from source MUST read:
+http://wiki.videolan.org/Win32Compile
+
+Bootstrapping VLC
 =================
 
-A typical way to configure the vlc is :
+If you retrieved VLC from the git server and do not have yet a "configure"
+script, please run:
 
-   ./configure --prefix=/usr --enable-gnome --with-sdl
+    ./bootstrap
 
-For a full compilation, you may try :
+Configuring VLC
+===============
 
-   ./configure --prefix=/usr --enable-gnome --enable-fb \
-           --with-glide --with-ggi --with-sdl --enable-esd --enable-alsa
+A typical way to configure VLC is:
 
-See `./configure --help' for more information.
+   ./configure
 
-Then, run `make', and `make install' to install it.
+See `./configure --help' for more information.
 
+If you intend to debug stuff, you may want to compile with debugging
+symbols:
 
-To build a Debian package, you may use :
+   make distclean ; ./configure --enable-debug
 
-   dpkg-buildpackage -rfakeroot -us -uc
+We recommend using GCC to build VLC, though some people reported success
+with the Intel C compiler (version 8) as well. GCC version 4.8 or higher is
+required. On older systems (e.g. FreeBSD 4.x), please select a more recent
+version manually by setting the CC and CXX environment variables
+appropriately while running the ./configure shell script.
 
 
-To build RedHat packages, use :
+Building VLC
+============
 
-   rpm -ba vlc.spec
+Once configured, run `make' to build VLC.
 
 
-Installing and running VideoLAN
-===============================
+Installing and running VLC
+==========================
 
-You can install the vlc and its plugins by typing :
+You can install the VLC and its plugins by typing:
 
    make install
 
-But you don't need to do it if you don't want ; vlc can be launched
-from the current directory as well :
+But you don't need to install it if you don't want to; VLC can be launched
+from the current directory as well:
 
    ./vlc
 
+
+Building packages
+=================
+
+To build a Debian package, you need to get the packaging info
+   git clone git://git.debian.org/pkg-multimedia/vlc.git debian
+and then
+   git-buildpackage