contrib: nettle: require GPL or GNUv3
[vlc.git] / contrib / src / nettle / rules.mak
1 # Nettle
2
3 NETTLE_VERSION := 3.3
4 NETTLE_URL := ftp://ftp.gnu.org/gnu/nettle/nettle-$(NETTLE_VERSION).tar.gz
5
6 ifeq ($(call need_pkg,"nettle >= 2.7"),)
7 PKGS_FOUND += nettle
8 endif
9
10 $(TARBALLS)/nettle-$(NETTLE_VERSION).tar.gz:
11         $(call download_pkg,$(NETTLE_URL),nettle)
12
13 .sum-nettle: nettle-$(NETTLE_VERSION).tar.gz
14
15 nettle: nettle-$(NETTLE_VERSION).tar.gz .sum-nettle
16         $(UNPACK)
17         $(UPDATE_AUTOCONFIG)
18         $(MOVE)
19
20 DEPS_nettle = gmp $(DEPS_gmp)
21
22 # GMP requires either GPLv2 or LGPLv3
23 .nettle: nettle
24 ifndef GPL
25         $(REQUIRE_GNUV3)
26 endif
27         cd $< && $(HOSTVARS) ./configure $(HOSTCONF)
28         cd $< && $(MAKE) install
29         touch $@