* ./configure.in: we now require autoconf 2.5x because previous versions
[vlc.git] / HACKING
1 $Id: HACKING,v 1.3 2002/08/26 20:49:49 sam Exp $
2
3 Hacking vlc
4 ===========
5
6 You will need the following tools if you plan to use the CVS version of vlc:
7
8  - autoconf version 2.50 or later
9  - automake version 1.6 or later
10  - gettext version 0.10.4 or later
11
12 After retrieving the CVS tree, you need to run the bootstrap script to
13 generate all the files needed to build vlc. You can then run configure.
14
15 If you do not have the correct version of these tools, or if they are
16 simply not available for the operating system you plan to develop on,
17 you can check out a CVS tree on an OS that provides these tools (such
18 as a recent Linux distribution), run bootstrap, and then copy the whole
19 tree to your retarded OS.
20