fate: fix fate-api dependencies