doc: Mention that DragonFly BSD requires __BSD_VISIBLE set